微信支付小吐槽

微信支付小吐槽

小程序调起支付 API 有个变量名用 关键字 这样不太好吧,在java 中属性名不能为package,这样我给前端转MD5很尴尬啊,

因为我是将java 对象转成xml字符串,再MD5签名,package不能作为属性名称。。。。吐槽。。难怪没有java sdk

The applet calls the payment API to have a variable name with a keyword, which is not very good. In Java, the attribute name cannot be package, so it is embarrassing for me to transfer MD5 to the front end, because I convert the Java object into an XML string, and then MD5 signs, package cannot be used as the attribute name.... Make complaints.. No wonder there is no Java SDK

回答:

peng:

我碰到过switch这个关键字,没办法,后面使用字典来处理。

Zach:要不来个微信支付开发相关 关键字收集挑战赛,哈哈

-EOF-